Login

GB2sequin - Browser Compatibility


GB2sequin requires JavaScript

 

GB2sequin was tested and runs fine in:

  • Mozilla Firefox, version ≥ 31
  • Google Chrome, version ≥ 36
  • Microsoft Edge, version≥ 38
  • Microsoft Internet Explorer, version≥ 11

Please let us know in case you experice any problems with GB2sequin in above mentioned browsers.