Login

GeSeq - Browser Compatibility


GeSeq requires JavaScript

 

GeSeq was tested and runs fine in:

  • Mozilla Firefox, version ≥ 31
  • Google Chrome, version ≥ 36
  • Microsoft Edge, version ≥ 38
  • Microsoft Internet Explorer, version ≥ 11
  • Apple Safari, version ≥ 9

Please let us know in case you experice any problems with GeSeq in above mentioned browsers.

 

GeSeq does not run in:

  • Apple Safari, version 5.1